TaxSys Outage

Incident Report for TaxSys

Postmortem

We determined that this TaxSys outage was caused by routine server maintenance. We regularly perform maintenance that does not require a scheduled outage window during off-peak hours to keep our systems secure and up-to-date. In this case, the maintenance process did not properly account for infrastructure changes we recently made. This caused the maintenance to affect live services instead of backup systems. Roughly 60% of clients experienced between 9 and 16 minutes of impact.

We are pausing similar maintenance activities while we implement additional safeguards to ensure our maintenance procedures properly detect and avoid impacting active services. We're also conducting a thorough review of this incident to identify all other necessary improvements to our processes.

Thank you for your patience as we worked to resolve the issue.

Posted Mar 25, 2026 - 16:42 UTC

Resolved

The issue that caused the TaxSys internal and public site outage for some clients has been resolved. This was caused by an issue with routine server maintenance, and we are working to apply safeguards to prevent this from occurring in the future.
Posted Mar 25, 2026 - 02:25 UTC

Investigating

We are currently investigating an issue that is impacting the TaxSys internal and public sites for some clients.
Posted Mar 25, 2026 - 02:09 UTC
This incident affected: TaxSys (Tax Collector Internal Sites, Tax Collector Public Sites).