Outage: TaxSys California Public Sites

Incident Report for TaxSys

Resolved

The issue that caused TaxSys California public sites to be unavailable has been resolved. This was caused by datacenter maintenance, and we were able to quickly find and correct the problem.
Posted Mar 08, 2026 - 13:59 UTC

Investigating

We are currently investigating this issue.
Posted Mar 08, 2026 - 13:50 UTC
This incident affected: TaxSys (Tax Collector Public Sites).