Degraded Performance: Public Site Payments
Incident Report for TaxSys
Postmortem

On Tuesday, September 3rd, at 1:12pm ET (10:12am PT), PaymentExpress staff deployed a routine software change which unexpectedly broke an API contract between our Public Site and our Payment Processing API. As a result, our Public Site was unable to lookup processing fees, which prevented customers from completing checkouts between 1:12 and 1:31 pm ET (10:12 - 10:31am PT). We restored service by reverting the problematic release.

This incident resulted from an unexpected difference in behavior between our production and non-production systems, which prevented our automated and manual testing from identifying the issue in non-production. We have found the bug that resulted in our production environment behaving differently from non-production, and are working to correct it in an upcoming release. Additionally, we will be improving our release monitoring to more easily identify issues with API consumers. This will allow us to more quickly recognize downstream errors and revert a release of our API if those consumers appear to be adversely impacted.

Posted Sep 06, 2024 - 13:50 UTC

Resolved
We have resolved the issue that caused degraded performance on our public sites. This issue was caused by a recent change we made in how we calculate payment processing fees. This issue prevented customers from making payments on the public site between 1:12 and 1:31pm ET (between 10:12am and 10:31am PT).
Posted Sep 03, 2024 - 17:55 UTC
Monitoring
We implemented a fix and are monitoring the results.
Posted Sep 03, 2024 - 17:31 UTC
Investigating
We are currently investigating this issue.
Posted Sep 03, 2024 - 17:12 UTC
This incident affected: TaxSys (Tax Collector Public Sites).